Learn Courses My Dashboard

App works on my device, but not at Apple

  • Set scheme to ‘Release’
  • Ran with iPhone 12 simulator – app works as expected
  • Ran with physical iPad 7 – app works as expected
  • Deleted app from iPad 7. Built and ran again – app worked as expected

I’m stuck.

With those changes made, why don’t you create your archive now and submit a new version to Apple.

Sent it to Apple last night. I hope it works. Sending the archive to Apple is not a very efficient way to debug a program.

If it still doesn’t work, is there a way I can use the archive to test the program the same way Apple tests it?

I’m not quite sure why you are suggesting that sending it to Apple is some way of debugging the program. If it works on all the simulators that you have tested it on then it ought to work for them.

Does it use any external data?

As far as I am aware the archive is specifically set up as a precursor to the App being placed on the App Store so you can’t run it “locally”, as you appear to be alluding to.

If you were an Enterprise Developer then that does give you the capability to install it onto other devices.

I agree. It ought to work for them, but it doesn’t. If I can’t reproduce the problem, all I can do is try something (at this point, I don’t know what) and resubmit it. They’re not “debugging” the program. I guess I should have said “testing”.

I found instructions on how to install the .ipa file onto a device, but when I followed the instructions, I was met with this message: “Unable to install ‘Bills & Periodicals’”. Not very helpful. I Googled the message, but that didn’t produce any useful information.

App rejected: blank screen.

You might have to take a leap of faith and have someone else take a look at your App to see if there isn’t something obvious that is wrong with it which is causing Apple to see a blank screen when they attempt to run it whereas you do not see a blank screen.

Without that you are going to remain in the position you are unless you figure it out all by yourself.

I’m happy to do that. Are you offering to do that? If so, I can send you my entire project if that works for you.

If you can figure this out, I’d be forever grateful.

This morning, I dreamed that I installed the app on my wife’s iPad and it started to spew out smoke. I think this is starting to have a permanent effect on my brain. :weary:

Pete, another option is to try to book an appointment for a developer lab at WWDC. OR, since you are a member of the Developer’s Program, I think you get 2 free support tickets annually?

Hi Peter,

Yes I am happy to have a look for you. I will private message you so that we have a communication mechanism in place.

I’m not familiar with the developer lab. I do get two support tickets. I’ve already used one, but I’ll go that route if Chris can’t find anything.

I have my project file in iCloud and it looks like there’s a way I can share it with you. When I get your private message, we can work it out.

Thanks for your help.

Hi Peter,

I did send you a private message. You should have a notification attached to your Avatar up the top right of screen. If you tap on that there should be an email icon you can select to view the message. Let me know if you see that.

@PeteTheGolfer

Can you log out of the forum and log in again. That may refresh your notifications.

Good news! After much research, I was able to reproduce the error using the .app file that was in the package.

Next, I created a new project and copied the source files from the old project to the new one. Created another .app file from this project and this time the error (blank screen) did not occur. Must have been something wrong with one or more of the project files.

Next step is to substitute the new project at the App Store. Stay tuned.

1 Like

Just received notification that my app was accepted at the App Store! All I did was copy the files to a new project.

I have to believe that it was a problem with Xcode.

Thanks to all who helped – especially Chris.

2 Likes

Great news.

You would not be the first person to have a project corrupted requiring a rebuild. Is it the fault of Xcode alone? Hard to tell as there may be other factors.