Learn Courses My Dashboard

Can't find solutions

Atm I’m starting the 14 day challenge and I can’t seem to find the solutions to the challenges… is annyone else struggling with the same problem??

Hi Tom,

Welcome to the Code Crew community.

If you go back to the Introduction section of the course there is a topic that says Resources. You’ll find what you are looking for there.

Hey the code for challenge 4 is working but I have this error:

Capabilities for Signing & Capabilities may not function correctly because its entitlements use a placeholder team ID. To resolve this, select a development team in the chanllenge4 (iOS) editor.

What could that mean?

What device are you trying to run the code on? Are you running the code on a simulator or attempting to run the code on a real device?

Hey, I am a new comer and just reached lesson 4 for beginners; first of all, I would like to thank you Guys for the work done, that is really amazing the way Chris is teaching, thanks for that. but I was also struggling at the beginning for finding the solutions for the challenges, luckily I found it; but I have noticed that there are no explanations about the methods that Chris gives in the solutions, for example for the challenge 4, he used that structure padding([.leading,.top,trailing] ; we did not used those format in the previous lessons, how can I be able to know why he wrote it that way ? even though I finished by getting it, but it was not easy. so isn’t it possible to give also a visual explanations of the solutions that Chris gives us in his solutions? because the purpose of those challenge is to understand all the concept before moving ahead. thanks you guys

I´m running it on a simulator… funny is that when I open chris blueprints and its exactly the same written code there is no such kind of error in his code… Maybe I have a false check in any setting?

Yeah I would also want to know more about that in lesson 9 I guess we have a connotation smth like: split.allWithTax(subtotal)… and so on. I would like to know why there is no other straightforward was to solve such a tiny problem…

In Lesson 11 in Resources contains just one zip called: L11 War Card.zip. There is no provided solution to the Lesson 11 challenge. Can you post it?

Also, fyi…expanding L11 War Card.zip correctly contains the solved War Card project but the project is incorrectly named: war-challenge. You might want to fix the naming on that project.

Thanks!

For what it is worth, this is my solution for that challenge set by Chris Ching.

struct ContentView: View {
    @State private var value: Int = 0

    var body: some View {
        VStack(spacing: 30) {
            Text("\(value)")

            Button {
                value += 2
            } label: {
                Text("Add 2")
            }

            Button {
                value *= 2
            } label: {
                Text("Multiply by 2")
            }
        }
    }
}
1 Like

Actually you can’t open the files. I tried it multiple times but there is no button to download the files.

@Aresch
Which course are you referring to? Is it the 14 Day Beginner Challenge (SwiftUI)?

yes the 14 Day Beginner …

When I go to “Resources” I only find 3 “Cheat Sheets”. And If I go to the Course curriculum
I can not click on the “resources” because it is not a “button” or “link” … it is just a text…
Do I need the “Pro” Version to download the files?

@Aresch

Is this what you are seeing?

yes right. But I can’t click just mark…Can you click on the lessons?

@Aresch

No, not on that screen.

Have you registered for access to the free content?

yes I did… Where can I download the files if not there?

@Aresch
So if you have registered for access then you have presumably logged in. Do you see a “My Dashboard” button up the top?

Yes I see it. What should I do?

Click on that option and you will be presented with the courses that you have access to.