Learn Courses My Dashboard

"Command PhaseScriptExecution" Error

Hey there!

I’m getting this error when trying to debug on my iPad device.

Command PhaseScriptExecution failed with a nonzero exit code

I don’t have an Apple Developer account, does that have anything to do with it? That’s the only thing I can think of so far.

That error does not seem to me to be an issue that is related to whether you do or don’t have a paid developer account.

Try cleaning the project (Shift + Command + K) and then try to build it again (Command + B)

If you have created a Developer account, but it is not paid, then there are restrictions on the number of Apps you can create in a 10 day window and there are restrictions on how many Apps you can install on a real device.

A paid account means that you can create as many apps as you like and put those Apps on your real device. Although I think that there are restrictions on the total number of authorised devices you can connected to your Mac but I don’t recall what that number is.

Hey @Chris_Parker!

I tried it out just like you said, and got this error instead:

framework not found FBLPromises

I’ve checked StackOverflow but can’t seem to find a good solution.

So how have you added frameworks to your project? Via Cocoapods or SPM?

Cocoapods

@Koderr

…and what are the names of the pods you have added?

‘Firebase/Firestore’

@Koderr

Ethan,

Have you tried updating (refreshing) your pod definitions for your project?

Close the project in Xcode and then open terminal and navigate to the project folder then run the command

pod update

I cleaned my project, updated my pods and everything is working now. Thanks @Chris_Parker !