Firebase module unrecognizable

When I tried typing “import Firebase” in my Xcode project under “AppDelegate.swift” an error popped up saying how that module was not found. I have followed all the steps up until this point and I even tried reinstalling my pod. Can you please help me out??

Assuming that you have installed the Cocoapods for the project, just do a build (Command + B) so that the complier is primed with all of the frameworks it has available.

When you then add the import statement you should not get any errors.

It’s still not working.

What are the pod definitions listed in your Podfile?

pod ‘Firebase/Analytics’

pod ‘Firebase/Auth’

I just posted a screenshot of my podfile incase it is needed:

maybe you forgot to open .xcworkspace and opened the original .xcodeproj instead

I opened it through the .xcworkspace though and I can see all the files of the Firebase

i had a recent experience when i also installed a pod and it didn’t get recognized, i suggest try to delete the current project and make a new one, maybe it just bugged out

One last suggestion: Have you tried cleaning the build folder? There is two types of “cleaning”:

  • Shift + Command + K which is the same as using the menu options Product > Clean Build Folder.
  • Shift + Option + Command + K which performs a deeper clean and causes the project to reindex the build folder.

If might be worth trying the second option first. When you next build the project it will take some time.