Full Stack iOS Notes App

Hi guys, I’ve been following along with the first three Full Stack iOS Notes App videos, but I have encountered a problem. The app is failing to decode the JSON returned from the server. I know it’s able to contact the server successfully as it displays the size of the database in the console(see photos) and I am able to add to the database from the simulator and verify that the note has been added by viewing the database in Safari. The delete function also works. I couldn’t figure it out, so I started the Xcode project from scratch (hey its great revision, right?) and the second build has the same problem.

can you try download the source code and compare to that one instead?

Hi, thanks for the reply, I haven’t seen any links to the source code for this video series as of yet. I’ll check the descriptions again to be sure.

I had the same issue.
After spending 1 hour+, debugging my code, i fixed it by just deleting all objects on my server… Then it worked again