Unable to run App from physical phone

Hi everyone,

My app runs fine in the simulator. However, I tried running the app from my iPhone but i am getting an error that states: Unable to launch because it has invalid code signature, inadequate entitlements or its profile has not been explicitly trusted by the user.

Has anyone come across this error? Would really appreciate any help.


Googling these issues often times yields immediate results and doesn’t clog up the forum with already answered questions:


There’s one link, there are many others if that isn’t your exact issue. I had the problem you’re referring to and had to go through a couple trial and error processes but it sounds like it’s a certificate signing issue.

Good luck!

HI Karsen,

Thanks. I tried googling it prior to submitting it in the forum but did not have any luck. Did not mean to “clog up” the forum. Just thought that as a newbie, this forum is an opportunity to clarify some things.

I managed to sort this out. It had to do with the device management setting in the iPhone. Thanks anyways.

Hey Zackbana,

Glad to hear you got this problem sorted! I also didn’t mean to say your question in particular was clog, I just wanted to emphasize that your problem was likely answered out there and that asking without searching first will ultimately lead to the ‘cloggage’ - lol. Glad to hear you tried searching for it and ultimately found a solution :slight_smile: