WarCardGame App launch Errors

Hi, Chris

I looked for groups to fix errors for WarCardGame. But couldn’t find it. Thus am writing it here.
My GitHub gist.

Hi @Deepak_Yadav Welcome to the community!

What is the error you are receiving? SIGABRT?

If that is the error, check all the objects you connected, it is likely you have one still connected it can not find the code because it was deleted or changed.

Let us know the error and we will see if we can help.

Hi, Mark

There is no error with SIGABRT. The app runs perfectly on the simulator. But when I install in on an iPhone7 iOS13.3.1 with XCode 10, it gets installed successfully, but never opens up when I tap on the icon.

Do you have a developer certificate selected? Also did Xcode report any error when you tried to run it on your device from Xcode? It should squack with an error message.

Sometimes the build can get hosed, delete it from your phone and try reloading it.


I added the developer certificate on XCode as well as "trust"ed it when I installed on iPhone7.
Also, the XCode wasn’t giving any errors earlier.
However, initially the XCode wasn’t running for iOS 13.3.1 because of some “developer” files missing. Then I added developer files for iOS13.3.1 from a github page

After which It got installed successfully. But doesnt open up when I tap on it.

Hmm, I would try and add a new Developer certificate.

Not sure why you would need to get an update from github, Xcode should pull down any updates it needs.

If all else fails, you can try and delete Xcode and reinstall. A pain I know since it is so large.


Yeah! It worked!.
I deleted XCode 10 and installed 11 from AppStore. It works perfectly now.