Xcode 11 equal widths not working

In Xcode 11.3 when I add an equal width in my story board. I’ve added a table view, initialized the prototype cell, added constraints to the table view. I then add a label inside the prototype cell, control click to add the equal width constraint to the label, but when the constraint is added, the constraint gets added with a 0.101449 multiplier. Is there a preference that is making this happen? I am able to move on by just changing the multiplier, but it’s a pain. I noticed it in the Quiz app, but now am on the news app and the same thing is happening. Am I doing something wrong?

1 Like

Hey Nelsom, you’re right!

I tried two different ways of adding the “Equal Widths” constraint and it yields different behaviors. One results in the behavior you describe (with the custom multiplier) and the other way results in the expected behavior. Check it out: https://share.getcloudapp.com/E0uEJYwN

I’m not sure if this is a bug in 11.3 or not. But try doing it the second way and see if you still get the unwanted multiplier!