Learn Courses My Dashboard

YouTube App (SwiftUI), Unable to Install CocoPod

May anyone please help, I have tried various different ways to install cocopod, but the terminal shows an error:



, Please help me I am struct as this from a long time

@Sam_Grover

Does your MacBook Air have an M1 processor?

Yes sir,

Got The solution, I didn’t know, M1 Macs needs a special treatment first :rofl:.

1. Open your Terminal under Rosetta and run sudo gem install ffi in terminal.

Open Finder > Applications > Utilities > Terminal > Right Click > Get Info > Open Using Rosetta
Open Finder > Applications > Utilities > Terminal > Right Click > Get Info > Open Using Rosetta

1 Like