Asset catalog doesn't display properly

Instead of displaying the colorsets that I’ve created, the asset catalog displays like this:

/* */
filename: Assets.xcassets
          filename: AppIcon.appiconset
          filename: Contrast.colorset
          filename: Positive.colorset

The colors that I’ve defined (when the catalog displayed properly) are still there, but I can’t add new colorists. I don’t know what I did to cause this.

Any ideas?

When an Assets catalogue gets messed up the easiest solution I have found is to recreate it.

In Finder, copy what’s left of the existing one to a another location on your Mac and then delete the existing one from within Xcode.

Now you can add a new one.

You can add it via the Xcode menu with File > New > File and then scroll down to the Resource section and choose Asset Catalogue.

If there are entries in the old catalogue that are still useable then drag them into the new catalogue in Xcode.

See how you go.

I already tried that. Tried it again, just to be sure. The new asset catalogue is messed up the same way.

I hoped not to have to do this, but I created a new project and moved the code from the old project into it. That fixed the asset catalogue, but the app isn’t working quite the same. I’ll work on that next.