Learn Courses My Dashboard

Can't Deintegrate and Install Pods

Hello!

I’ve uploaded my project to GitHub, deleted it on my local computer, then cloned it in a different location on a hard drive. I successfully opened the project on my computer, but when I try to reinstall my Pods using pod deintegrate and pod install, I get this error:

[!] Could not automatically select an Xcode project. Specify one in your Podfile like so: project 'path/to/Project.xcodeproj'

I think it may have to do with the fact that it’s in a differnent location on my local device than before, but I’m not sure. It could also be that the pulled project isn’t “up to date” with the current project in GitHub, which I don’t see why that would be the case.

Any ideas?

Sounds a little odd and I can’t say that I have ever encountered that issue. Which of the two commands in terminal gave you that error message? Did pod deintegrate run successfully?

@Chris_Parker Here is what I have tried…

Notice how the pods portion of the project is still no longer in the workspace.
Screen Shot 2022-07-09 at 5.59.40 PM

I also do not see the Pod file in the folder… Am I looking in the wrong place? I believe it should be somewhere in here…
Screen Shot 2022-07-09 at 6.11.57 PM

I found the solution, but I’m not sure why it’s the solution:

I cloned the repository in my Documents folder on my Mac (the original location of the project before I removed it from my computer) rather than an external hard drive. I was then able to use pod deintegrate and pod install successfully.

I’m not sure why it had to be cloned at the same location as it was created?