Learn Courses My Dashboard

Card match Game : Landscape mode is not getting fixed

I have a question that I have fixed the check only to landscape in Xcode deployment settings but while running the app , the portrait mode is still showing itself . Help me solving this problem . The other thing is that in your tutorial when you open the Xcode deployment settings only one box of 'upside down ’ was ticked . while in my case all the boxes are unticked , Help me resolve this issue .


So this screen appears as I open the Xcode deployment settings. Now I have ticked only last two boxes , so the app must work only in landscape mode but it is still working in portrait mode .

@Huzaifa

Welcome to the community.

As long and you have checked the boxes for Landscape Left and Landscape Right, as indicated by the arrows on the attached image, you should be right.

If the simulator is sitting in Portrait mode initially it should switch to Landscape as soon as the App launches and shows the UI.

Yes exactly , it should work but this is happening as shown below:

Regards.

Any idea what can be the issue ? Also you’d have noticed that initially my “portrait” , “landscape” boxes should be ticked as in your case they were , but in my case all boxes are unchecked . Point is that the device orientation doesn’t change its behaviour at all , even if you tick or untick any of the boxes .

From the simulator Menu, select “Device” and make sure that “Rotate Device Automatically” has a checkmark against it. If it does not then click that option so that it is “set”.