CFbundleIconName not found in info.plist? But it's there! :)

I built an appicon set over at and although the image set filled all the “wells” (including the appstore one at the bottom that’s 1024x1024) when I build to test Apple emails and says there is no item in the info.plist for CFbundleIconName.

I can see it there, and I’ve tried using icon files, icon file, etc. The file in the asset group is 1024.png.

Let me get a screen shot of what isn’t working.

Screen Shot 2020-08-31 at 9.28.31 AM

Hi @thirtywest

The App Store ICON needs to be .jpg. A .png will work, but it needs to be stripped for the web. I found just creating a 1024 .jpg is the full proof solution.


Whaaa? Ok, where does it say that? I mean, I’m going to go try that, but the documentation is all over the place.

Ok, I noticed that Xcode yelled at my image that was made in photoshop (trying to manually manage one for a moment) showed 47xx x 47xx even though I set the canvas to 1024x1024 pts. Xcode said any DPI as long as the points are 1024.

  1. I’ve made icon sets at and they work except for the App Store.

  2. I’ve made custom JPG and PNG now, at 1024 points AND 1024 pixels.

  3. I add it from the plist and make sure the Info property list says “icon files” and the item to the right says 1024.jpg (or it’s been 1024.png too) and they don’t work.

  4. 21 builds now and I keep getting the email from apple. I don’t even need it because I can tell my app in “apptstoreconnect” has the placeholder for the icon by the app name.

  5. I’ve been eyeing the single malt scotch on the shelf over there…

  6. I don’t regret posting #5 out loud.

Hmmm. I have never had to adjust the plist before. Xcode should handle that automatically.

If you are not getting a warning about the wrong size, and the image is .jpg I would try and remove any edits o made to the plist and give that a go.

Good luck. I DO understand about the scotch. I have been banging my head against the keyboard for weeks upon weeks now tying to get iCloud Sharing to work–it too as dismal documentation.



Originally I just let Xcode do all the images. It was only after I got the first cfbundleiconname error that folks started mentioning going into the plist.

I thought if the plist said “appIcon” and the asset folder had that too, that’s all you would need.

I’m going to pull all the icons and start over.

Do you recommend any site for making all the different icons?

I use an app called App Icon Resizer

I can’t remember if it a paid app, and it has worked with your fail for me.


It’s so darn odd.

I just started over with a fresh 1024x1024 jpg.

I went to “” and made the set.
I removed every image from my project.
I swapped the xcasset folder with the one that site made.
Opened my project and all the icons were populated seamlessly.
Ran it on simulator and get the icon on the home screen.
build and upload fine.
Go to appstore connect and the store icon ain’t there…again. 23 tries now.

I tried the app you suggested. It built a set. I loaded it fresh over the asset folders in my empty project.

I can already see it’s building fine but the appstoreconnect icon isn’t there.

This is the folder it produced.

Still getting the error: "A value for the info.plist key ‘CFBundleIconName’ is missing in the bundle .

But, I have a value for that–I’ve tried lots of values for that key. 1024.png, 1024.jpg, AppIcon, etc.

I tried putting a 1024x1024 image in the well for the store but no joy.

Hmmm. Which version of Xcode are you using?

Assets.xcassets should have a folder in it name AppIcon in which you drop your icons.

In the list, iOS-marketing.png is the App Store icon, but as I indicated above, it needs to be a non-transparent 1024 jpg I just save an additail jpg in Sketch when I create the original 1024 .png for the Icon generator app.

The correct string for CFBundleIconName is:


But I have never had to add that, so not sure why you are having to add it manually. CFBundleIconName error is typically simply missing the 1024 jpg in the app store slot.

It is a mystery what is going on with your machine.


I’m using 11.7

What’s the folder heirarchy?

can you write>them>so>I>can>ensure>ordering?


I don’t think it matters where you place it, when I add something to the pList, I add it as the last item.

I would advise removing it and clean the project and build the project, ensure you have a .jpg in the Apple Store slot.

I do not have CFBundleIconName in any of my projects.


ok, I cleared all images. even deleted the Assets.xcassets from Xcode.

Created a new one and loaded the stuff in it. This is inside Finder, and this is what shows for AppIcon

Screen Shot 2020-08-31 at 5.42.22 PM

Screen Shot 2020-08-31 at 5.43.28 PM

I am no sign the beta version oof xCode. maybe there is a bug.

App Store 1x is a .jpg right? The one you show above is .png, this will not work. If a .jpg, that should build and deploy correctly then.

Also, did you drag the folder into the build folder via the Finder or drag them onto the AppIcon slots in xCode individually? I have always done the latter and never had a problem.


I built using the program you recommended. I copied the folder to the proper path and they propagated on their own.

if this doesn’t work I’ll try it the other way.

Yes that’s a png. You said jpg. So, I’ll dump it to photoshop and resave it as a jpg with no other changes.


I changed the file to a jpg, but had to lower it’s size to “medium” in photoshop. It passed the build and Apple emailed me stating so.

However, in the AppstoreConnect area, the app shows no icon next to the title.
It shows an icon down by the file and build number, but the top one is blank (is that normal?).

Glad to hear you got it sorted out.

As long as the build you uploaded and the App store slot on the webpage are correct (see pict below) you should be fine. It may not propagate above until the app is approved. I can’t remember.

The Apple Connect web site can be funky at times.

Good luck getting it through the gauntlet!

I think your app works better than the site I visited; it put an extra folder in there and got the hierarchy out of whack. it’s being reviewed for test flight now.

Thank you, sincerely, for the time taken. It’s thick work, and I know how busy dev’s are with legit projects.