Learn Courses My Dashboard

CocoaPods error

I want to use in my app @DocumentID which is available only if you have FirebaseFirestoreSwift CocoaPod.

I added it to my Pod file, but when I struggled with all the possible errors ( I think I googled how to escape from pod install errors for two days ) I have this error in the end:

Analyzing dependencies
[!] CocoaPods could not find compatible versions for pod “FirebaseFirestore”:
In snapshot (Podfile.lock):
FirebaseFirestore (= 8.1.0, ~> 8.1.0)

In Podfile:
Firebase/Firestore was resolved to 8.1.0, which depends on
FirebaseFirestore (~> 8.1.0)

FirebaseFirestoreSwift was resolved to 0.4.0, which depends on
  FirebaseFirestore (>= 1.6.1, ~> 1.6)

Any help please?

Here is my Pod:

Uncomment the next line to define a global platform for your project

platform :ios, ‘11.0’

target ‘…’ do

Comment the next line if you don’t want to use dynamic frameworks

use_frameworks!

Pods for “…”

pod ‘Firebase/Auth’
pod ‘Firebase/Messaging’
pod ‘Firebase/Database’
pod ‘Firebase/InAppMessaging’
pod ‘Firebase/Firestore’
pod ‘Firebase/Analytics’
pod ‘Firebase/Functions’
pod ‘Firebase/Storage’
pod ‘Firebase/Crashlytics’
pod ‘Firebase/DynamicLinks’
pod ‘Firebase/RemoteConfig’
pod ‘Firebase/Installations’
pod ‘Firebase/Performance’
pod ‘Firebase/InAppMessagingDisplay’

pod ‘FirebaseFirestoreSwift’

end

And yes, I tried modifying the deployment target and iOS platform, but still the same error…

And I finally installed pod FirebaseFirestoreSwift

But, there is no import in Xcode: import FirebaseFirestoreSwift -no such a file or directory

It would be best to check the documentation of this on cocoapods.org… It might be outdated now espacially if you are using the latest version of xcode