CocoaPods Problem

I’m trying to CocoaPods installed so I can use FireBase in my app

The top window is my pod file (it seems to have an extra “end” statement compared to the one in Chris’ video).

The bottom window is my terminal with the error messages (I don’t even know what they mean).
Sadly, I don’t know enough about what I’m doing to have a productive Google search and the other CocoaPod threads didn’t seem to address my issue.

Any suggestions?

I’m wondering if it is a problem with the path? I had trouble getting terminal to cd to a folder that had a space in the name. Could that be part of the problem?

dont use zsh in the terminal as it wont work properly

go back to bash using

chsh -s /bin/bash

it didn’t work before I zsh. As far as I could tell it’s the same result. What does zsh / bash do anyway?

it seems that firebase core does not exist anymore because its not in the documentation

you need to install Auth and Firestore now instead of core and database

pod ‘Firebase/Auth’
pod ‘Firebase/Firestore’

zsh and bash are like programming languages for the terminal, the basic and most commonly used is bash so use that instead, don’t know why apple decided to add zsh

THANK YOU THANK YOU!! That seems to have worked. Now if I can remember why I wanted to do that in the first place :laughing:

1 Like