Error downloading cocoapods

I’ve been searching for a solution for this problem since last month and couldn’t find any help on the Internet. I was just hoping to find anyone with a solution for this problem over here! Please if you have any idea or solution to my problem, don’t hesitate and reply back ASAP!

Try sudo gem install ffi

Try to make sure you’re Ruby gems is up to date and then install cocoapods

I have tried sudo gem install ffi and it didn’t work.
I have also updated my ruby gems and tried installing cocoapods still gave me the same error!
I don’t know what to do anymore…

Thanks for the help tho!!!
really appreciate it!

Make sure you are running terminal with full permission maybe your security ia preventing it.

You can also check out our cocoapods tutorial as well https://codewithchris.com/cocoapods/

Thank you all for the support, I really appreciate it!!!
I have solved the problem myself as there was a problem in my own imac and I fixed it.
Again Thank you all again for all the help!

1 Like

I also had this issue and what I did helped a lot.

Try changing the default shell of the terminal to “zsh”.