Error Message in console by running apps (from tutorial)

Hey community,

in every app tutorial we made here i got this error message in the console by running the apps:

nw_protocol_get_quic_image_block_invoke dlopen libquic failed

can someone tell me why i got this everytime?

Thank you guys for any help


Hi Flo,

Are you trying to call an AVPlayer in the simulator?

If so, Apple said three months ago that there was a bug in the simulator that they are trying to fix.

Does if happen on all tutorials? Which version of Xcode are you using?

Will try and help you sort it out.

I get this same error too…running Xcode 12.0.1. I am working on the Firebase Module 1 Lesson, haven’t seen this before working with Firebase.

Any help would be appreciated.

Ignore it folks. I get the same dumb messages in my project too and it was completed months ago. I suspect that it is an Xcode 12 simulator issue.

1 Like

Hey guys,

ok i will ignore it. But just for record, i got this message in the following made apps:

  • news App
  • quiz app

Journal App and Match App are working without error message while simulating.

  • Flo

Hello Guys,
I am getting the same issue each time I run the API. I am using Xcode version 12.2.

You can just ignore it, I got that error message too. But if something is not working, make sure Firebase Database is NOT locked up, ; letting user type, edit in Firebase.