Error with the custom login dem building

Hello again! I have since fixed my last issue but it seems there is now another. when I try and build the project I receive this error.

‘GoogleUtilities/Environment/Public/GoogleUtilities/GULSecureCoding.h’ file not found

I’ve tried updating pods, and it didn’t seem to work I’ve checked to make sure my pods are correct and I think they are but ill include those as well.
I’m new to all this and am trying to teach myself so I appreciate the help!

here are the screenshots of the error message and my pod file.

Try cleaning your build folder. The keyboard shortcut is Shift + Command + K

The other thing you could try is to close your project and in Finder navigate to your Xcode DerivedData folder and remove the project entry from there. This is where Xcode builds (complies) your project and is where it creates the executable version to load into your simulator.
Deleting it is no problem as it will be re-created the next time you open the project in Xcode but the contents will be fresh and unaffected by any previous code.

The simplest way to navigate to that folder is to go to your Finder menu and tap on the menu option Go > Go to Folder.
Copy and paste the following into that field:
and tap on Go

Scroll through contents of that folder until you find your project. Move it to the bin.

This action may not solve the issue but it’s good house keeping nevertheless.

wow! I spent over two hours trying to figure that one out haha thank you! the second one seemed to fix that issue but now it’s left me with a new one.

35 duplicate symbols for architecture x86_64

Any idea what this is or how to fix it?

Did those errors (warnings) come up after you tried to Build the project?

yea sorry after I tired to build it

Did your login page successfully link with firebase? Because I was watching the video and firebase checks to make sure the two have successfully linked and it did not do that for mine. Did I do something wrong?

Yea mine didn’t do that either and so I built a few other tests to see if it would and it still didn’t so I’m assuming that’s now not a part of the setup for whatever reason. However, now when I go into my firebase project it shows reads and writes in a little graph reflecting the times I’ve built the project so I would say that means it’s all linked. So if you have those I would say you’re good and everything is linked!