Learn Courses My Dashboard

Failing to show simulator and code not running

Hey Chris, I tried the war game challenge as you said in the solution but when i run it on the simulator it says Unable to boot device due to insufficient system resources. Though i get it on the preview page i still did not get the background to be fully covered. I dont know whats the mistake. I will attach the snippet of the code and preview in this.

!

You need to add .all inside the parentheses for ignoreSafeArea

And you can’t click the play button or Cmd + R? It gives you an error?

@mikaelacaron i tried inserting .all inside the parantheses but it didnt work. When i click Cmd+R or play button sometimes it throws an error. Havent got that in a while i guess its fixed now. Thanks for your help. And I think since i chose iPhone 12 Pro Max as my simulator i didnt get that, when i gave iPhone 11 as my simulator it worked. I am not sure why.

When you create a brand new project, without changing anything, run that on the iPhone 12 Pro Max and iPhone 11 simulators do you get any errors?

Did not get any errors on both but when i run on iPhone 11 the background of the war challenge comes fits the screen completely but when it is on the iPhone 12 Pro Max(which the system takes as default) there are some gaps in the ends other than the top.

On your Image(“background”) use the following modifier.

.edgesIgnoringSafeArea(.all)