Firebase Auth Tutorial

I’m following this tutorial, at minute 39:35 my build fail even though i followed every single step of the tutorial. The reason behinde the build fail is a number of errors occurred in the “GoogleDatatTransport” folder:

as you can see in the screenshot.

Can someone explain me why i get all this errors and how to fix it?
Thank you!

UPDATE: i deleted and then reinstalled podfiles and runned it again -> failed once again

There is a setting in the project that you need to change so that the double quoted include files are not seen as an error.

For example, see this project screen:

Select the top level of the project in the Project Navigator
select PROJECT
select Build Settings
select Combined
Narrow the search to the word “quote”
make sure that the option “Quoted Include In Framework Header” is set to NO

1 Like

thank you! it worked, i still have to learn these tecnical things, really thank you so much!

Hi, I am having a similar error. However, my “Quoted Include In Framework Header” is already set to NO, but I am still seeing these errors. Not sure how to fix this

Also check the Pods to ensure that the same setting is changed there too. See the attached image.

1 Like

Now i’m gettin this error:

Thanks that worked for me. The problem is, I keep getting random errors every so often. Before i was getting an error to do with the environment now im getting:

“‘GoogleUtilities/MethodSwizzler/Private/GULSwizzler.h’ file not found”