Firebase Authentication/Cocoapods Problem

I was loosely following the Firebase Authentication tutorial to add a login screen to my app, but when I installed the Podfile Xcode started being super buggy. I’ve been able to resolve most of my issues on my own, but this one’s got me stumped. When I run, the project spends 3-4 mins building before throwing this error " clang: error: no such file or directory: ‘nanopb’. Command Ld failed with a nonzero exit code". This confuses me because that directory in the same group as all of my other Podfiles which don’t throw any errors. I’ve tried deleting Derived Data and cleaning my build, but nothing has helped. Anybody have any idea what I can do to fix this? I really don’t want have to rebuild my entire app from scratch because of this. Thanks!

Hi @Alex_Weiss

Welcome to the community!

Before you go throughth huge hassle of starting over, try and remove the pods with this in Terminal:

 pod deintegrate

Then you can also run pod clean but I usually don’t.

Reinstall pod install and see if that restores the missing file.


I forgot to mention – I had actually tried deintegrating and then re-installing (although admittedly I didn’t try and run pod clean). If I can’t come up with a better answer soon I’ll try that (and given the weird things Xcode has been doing, a second try might be all it takes). Thanks for the suggestion!

Update: deintegrating and reinstallling did not get rid of the error.

I’m on a pretty tight deadline so I’m just gonna rebuild the app (which shouldn’t take too long since it’s all programmatic so it’ll just be some copy and pasting) but I’ll leave this thread open because it would be nice to know what wrong/so others can fix their projects if this problem arises.