Firebase Authentication error File not Found

I am quite new to programming and currently trying the Firebase Authentication Tutorial 2020 - Custom iOS Login Page (Swift).

I have tried it a few times now and rebuilt the app as well, but I keep getting the same error.
absl/numeric/’ file not found

It looks like it is a problem with the FirebaseFirestore app. Does anyone know how I can fix this? I have imported Firebase in the AppDelegate and my podfile is similar to the one in the tutorial.

(I hope this is enough background information to solve the problem, if not, I am happy to give more needed information.

This is an issue in the Firebase file, so something may not be getting downloaded correctly.

After installing pods make sure you’re opening the .xcworkspace, not the .xcodeproj file?

I’d look into updating your cocoa pods, and/or updating the pods you have installed

Am facing the same issue above. Can anyone plz help?

I tried updating to latest cocoapods and updated the pods as well. but still facing the same issue.