Learn Courses My Dashboard

Firebase -- Did not find header

Hello,

This is Louis. I was running out of hard drive space in MacBook. I bought a removal drive and move all my files and including xcode there. Here is the error that I have been getting:

/Volumes/Mac Extension/FetalGrowthPercentile/Pods/FirebaseAuth/FirebaseAuth/Sources/AuthProvider/Phone/FIRPhoneAuthProvider.m:20:9: Did not find header ‘Sources/Public/FirebaseAuth/FIRAuthSettings.h’ in framework ‘FirebaseAuth’ (loaded from ‘/Users/littlemathematician/Library/Developer/Xcode/DerivedData/FetalGrowthPercentile-byygvcbyszmotwdwyjqbnpugaypf/Index/Build/Products/Debug-iphonesimulator/FirebaseAuth’)

Please Help!

Try searching the Mac App Store for DevCleaner for Xcode and run that and see if that cleans up some of your old Xcode build files to free up space

Have you cleaned the project (Cmd+ Shift + K) and built again? And deleted derived data and build again?

Because even if Xcode is in a different location it’s log files and where it’s trying to build is on the MacBook still

Dear Mikaela,

I had tried the following:

  1. Dev Cleaner
  2. Cleaned the project
  3. Delete Derived Data with rm -r

I may try the swift manager by disintegrating Cocoapods next. Thanks.

Yeah it seems to be with the dependency caching something

So fully removing it and reinstalling may be your best bet

I’d also recommend keeping the app itself (Xcode) on your computer

But the files you have move those to an external hard drive

Thanks. Problem was solved. I got a new MacBook. That was all it took. I was running Xcode with the hard drive. My app started working again. Thanks!

1 Like

Gotcha, sounds like you can keep projects elsewhere, but Xcode should stay running on the hard drive itself