Learn Courses My Dashboard

Firebase- Error with FirebaseCore

Hello!

I was working on an app that uses several pod files including Firebase Core, Auth, Database, etc.
It was working fine until I needed another pod, so I inserted another line to the pod file and installed it again.
After the second installation, I cleaned my build folder, and I got an error message saying “FirebaseCore/FirebaseCore.h file not found” and “Could not build Objective-C module ‘Firebase.’” This has happened to me before when I installed a pod after the initial pod installations

I have tried deleting my Derived Data folder and deleting and re-downloading pod file.

Does anyone have a solution to this problem?

Thank you in advance.

Try pod deintegrate

This will remove them from the project and then do a pod install to put them back in the project

Also again delete derived data and restart Xcode

And then finally try to open the project and see if it works.

I have tried that, and I am still getting the error message.
Do you another way I could try fixing this?

I had the same issue when re-opening the project from the Welcome to Xcode dialog on xcode restart.

When I opened the project by calling open Firebase\ Demo.xcworkspace from the terminal, I no longer had the error.