Learn Courses My Dashboard

IAP- Missing Meta Data

Hi guys, I started the journey to release my first App back in November 2021.

Finically, after months, we have been able to work through the various obstacles to get to a point that for the most part that us and Apple are happy.

With that said, we are facing an issue.

In app purchases have been configured, tested and seem to be working however, on the Apple Connect side of things, under the subscriptions, it says ‘missing meta data.’

I have tried uploading a screenshot under that tab and filling out review notes. I have tried adding localisations but still, I can’t get it to configure without saying ‘missing meta data’

I have contacted Apple and they are no help. Shock.

I would appreciate any and all help from the CWC family.

Thanks

Welcome to the community!

Have you set the price and filled out all the proper info for submitting the app to the App Store?
I’d highly recommend doing this on a desktop rather than a phone

Have you submitted the image of where this appears in the app?

Hi Mike,

Thanks for your reply.

I only used a phone for screen shot purposes, everything was done on desktop and included the prices/duration.

The IAP’s worked in a test environment which is even more confusing.

Any input would be appreciated.

Thanks again

Hi @EOA Please try asking Apple again! Sometimes you just need to remind them about your concern and ask for more information about the missing requirements.

It also happened to me, and the reason for my suggestion to you is that it works for me twice already. :grinning_face_with_smiling_eyes:

1 Like

Hi @mikaelacaron and @joash amazing from both of you. Thanks

So I resolved the issue- by chance.

As stated, Apple were no help at all, the individuals I spoke to, tried their best but ultimately , I got an email from them saying they are not developers.

Anyway, the solution turned out to be adding an image to the in-app-subscription review.

I had previously tried that and it hadn’t worked. The key was, the image dimensions. The dimension that ended up working for me was 2208 x 1242

There is nothing that states there is a minimum size requirement for the review screenshot but THAT was the issue.

I hope this helps someone else.

Fast forward, I was able to get the app approved after 9 months. (There were other issues) and I am ready to move forward to the next stages of the project.

Thanks again for you help.

1 Like