Learn Courses My Dashboard

In App Purchases - HELP!

Hi there,

I’ve very recently built my app and got my Apple Developer licence. I’ve been following Chris’ excellent YouTube tutorial on in app purchases with Revenue Cat but hitting a problem. I’ve run the cocoapods install and everything went fine but when I come to build my app I get a nonzero exit code failure. The error message is below. It looks to be something to do with a missing folder but I’m very new at this so unsure how to interpret this. Any help would be amazing.

Thanks

Chris

kdir -p /Users/boosh/Library/Developer/Xcode/DerivedData/Let’s_Quiz_It-cddntznachqcytgedvsimrhqvwyb/Build/Products/Debug-iphonesimulator/Let’s Quiz It.app/Frameworks

rsync --delete -av --filter P .*.??? --links --filter “- CVS/” --filter “- .svn/” --filter “- .git/” --filter “- .hg/” --filter “- Headers” --filter “- PrivateHeaders” --filter “- Modules” “/Users/boosh/Library/Developer/Xcode/DerivedData/Let’s_Quiz_It-cddntznachqcytgedvsimrhqvwyb/Build/Products/Debug-iphonesimulator/Purchases/Purchases.framework” “/Users/boosh/Library/Developer/Xcode/DerivedData/Let’s_Quiz_It-cddntznachqcytgedvsimrhqvwyb/Build/Products/Debug-iphonesimulator/Let’s Quiz It.app/Frameworks”

building file list … done

Purchases.framework/

Purchases.framework/Info.plist

Purchases.framework/Purchases

Purchases.framework/_CodeSignature/CodeResources

sent 660345 bytes received 92 bytes 1320874.00 bytes/sec

total size is 659929 speedup is 1.00

Code Signing /Users/boosh/Library/Developer/Xcode/DerivedData/Let’s_Quiz_It-cddntznachqcytgedvsimrhqvwyb/Build/Products/Debug-iphonesimulator/Let’s Quiz It.app/Frameworks/Purchases.framework with Identity -

/usr/bin/codesign --force --sign - --preserve-metadata=identifier,entitlements ‘/Users/boosh/Library/Developer/Xcode/DerivedData/Let’s_Quiz_It-cddntznachqcytgedvsimrhqvwyb/Build/Products/Debug-iphonesimulator/Let’s Quiz It.app/Frameworks/Purchases.framework’

/Users/boosh/Library/Developer/Xcode/DerivedData/Lets_Quiz_It-cddntznachqcytgedvsimrhqvwyb/Build/Products/Debug-iphonesimulator/Lets Quiz It.app/Frameworks/Purchases.framework: No such file or directory

Command PhaseScriptExecution failed with a nonzero exit code

Hi Chris, what version of Xcode are you using?

Does cleaning the project (Cmd + Shift + K) and running it again fix it?

Hi Mikaela,

I’m using XCode 12.5.1. I’ve tried cleaning it and unfortunately that doesn’t fix it. I’m at a total loss as to what to do. This is probably beyond my skillset but I wanted to challenge myself. Is there any more information I can provide which could be helpful?

Thanks a lot

Chris

Chris,

What’s the name of your google info p list file?

Hi Mikaela,

Thank-you for your help. I decided to try again on a new xcode project and it worked fine. So I’m going to use that as my start point and import my code from my other app (it’s not loads so not tonnes of work). It’s a lesson for the future!
Thanks again

Chris

1 Like