iOS Databases - Module 2 / Invalid Google Plist?

iOS Database - Module 2 - 2nd video

Here Chris ran the app and connected to the firebase database for the first time. Ive tried this twice and each time it has failed, at the same spot.

I’ve googled and tried their solutions. Where should I start troubleshooting?

Can you paste the entire output log at the bottom right?

Did you drag the google info.plist into the project?

2020-08-31 18:50:55.911858-0400 Note taking App[28328:168804] 6.31.0 - [Firebase/Core][I-COR000012] Could not locate configuration file: ‘GoogleService-Info.plist’.

2020-08-31 18:50:55.968300-0400 Note taking App[28328:168553] *** Terminating app due to uncaught exception ‘com.firebase.core’, reason: ’[FIRApp configure]; (FirebaseApp.configure() in Swift) could not find a valid GoogleService-Info.plist in your project. Please download one from https://console.firebase.google.com/.’

*** First throw call stack:

(

0 CoreFoundation 0x00007fff23e3de6e __exceptionPreprocess + 350

1 libobjc.A.dylib 0x00007fff512539b2 objc_exception_throw + 48

2 CoreFoundation 0x00007fff23e3dcac +[NSException raise:format:] + 188

3 Note taking App 0x000000010196ea02 +[FIRApp configure] + 130

4 Note taking App 0x000000010196a4d7 $s15Note_taking_App0C8DelegateC11application_29didFinishLaunchingWithOptionsSbSo13UIApplicationC_SDySo0k6LaunchJ3KeyaypGSgtF + 71

5 Note taking App 0x000000010196a5b3 $s15Note_taking_App0C8DelegateC11application_29didFinishLaunchingWithOptionsSbSo13UIApplicationC_SDySo0k6LaunchJ3KeyaypGSgtFTo + 211

6 UIKitCore 0x00007fff4931c614 -[UIApplication _handleDelegateCallbacksWithOptions:isSuspended:restoreState:] + 232

7 UIKitCore 0x00007fff4931dfb3 -[UIApplication _callInitializationDelegatesWithActions:forCanvas:payload:fromOriginatingProcess:] + 3985

8 UIKitCore 0x00007fff49323b75 -[UIApplication _runWithMainScene:transitionContext:completion:] + 1226

9 UIKitCore 0x00007fff48a2c1a6 -[_UISceneLifecycleMultiplexer completeApplicationLaunchWithFBSScene:transitionContext:] + 179

10 UIKitCore 0x00007fff49320063 -[UIApplication _compellApplicationLaunchToCompleteUnconditionally] + 59

11 UIKitCore 0x00007fff49320362 -[UIApplication _run] + 754

12 UIKitCore 0x00007fff49325968 UIApplicationMain + 1605

13 Note taking App 0x000000010196acab main + 75

14 libdyld.dylib 0x00007fff520ce1fd start + 1

)

libc++abi.dylib: terminating with uncaught exception of type NSException

(lldb)

Yes I dragged the Google infoplist into the workspace. However I dowloaded multiple instances of google plist and eventually it was infoplist-1 and infoplist-2 and so on, But i read the advice that I should rename it to GoogleService-Info.plist so I did and still nothing

When copying it into the project make sure “copy items if needed” is checked, and that it’s going into the proper project

1 Like

The “i” in plist was lower cased and should have been upper cased :see_no_evil:

That’ll do it :joy:
It happens