Missing ViewController in Assistant Editor

Hey, I got this problem that I can open the assistant editor with the right view controller of the storyboard until I group the view controllers co. on the left side.
Why is this happening and what can I do about?

What do you mean “until you group the view controllers on the left?”

You can always manually select the file

Hi Fabian

The easiest way to make sure that you open the correct ViewController.swift file in Assistant Editor mode is as follows:

  • Select your Main.storyboard
  • Press and hold the Option key and then click on the swift file you want to connect Outlets and Actions to.
    This will work every time and you will always get the right swift file opened.
1 Like