Learn Courses My Dashboard

Module 5 Lesson 6 Challenge VideoPlayer

Hi guys, I keep getting a nil on my pathString variable from playing a local video on the challenge, even though the file was literally inside the project.

@RyanChristian

Hi Ryan,

Check that the video that you added to your Bundle has it’s “Target Membership” set.

Select the file.
Look at the right hand panel (you may need to open it by tapping on the icon in the top right corner)
Select the Page icon (File Inspector)
Ensure that the Target Membership is “checked” for your App name.

1 Like

Sir Chris I already checked that while adding the file and upon checking now it is still checked under my App Name please see attachment below for your reference sir.

Sir I found the solution base on the image i attach sir thank you for helping me out sir, On the second image I sent sir on my reply to your comment I saw the name on the file inspector it has a white space between the file type now ts working sir thank you very much!

Great to hear you fixed the problem.

What you can do is change your Xcode Preferences so that the file extension is shown for each of the files in the File Navigator panel on the left in your Xcode window.

From the Xcode menu select Xcode > Preferences
In the General tab change the setting for “File Extensions” to Show All

That will help you see if there is any mistakes in file names.

1 Like