My App Development Learning Journey

Whee! I finally started a journal! Woo. Anyways, I’m starting this journal a bit late. I have completed the 29 day beginner challenge, the SwiftUI course on YouTube, and I’m enrolled in CWC+. I’m on the iOS Foundations Course and I have completed the QuizApp. I am now working on the NewsApp. I give you guys an update later. See Ya!

1 Like

Great to hear Bach! You’re doing awesome!

Oh great. Just what I needed. An error. I am working on my NewsApp. I have subclassed UITableViewCell correctly into ArticleCell, and I declared ArticleCell’s custom class as ArticleCell.
Here are some screenshots of my error.
You can see here that ArticleCell’s Custom class is ArticleCell.


And you can see in this screenshot that in the assistant editor there is no option ArticleCell.swift.

Can someone help me?

Thanks!

Did you set the Custom Class in Storyboard?

Yes. I did set the custom class to ArticleCell.

@Bach_Nguyen

If you are having trouble getting the assistant editor to link the right ViewController to the storyboard then try this:

The simplest way to get Xcode to open up in Assistant Editor mode AND make sure that it is linked to the right ViewController is to start with the storyboard selected.

Next is to hold the Option key down and then click on the ViewController.swift file (or whatever the file is that you want to connect objects to) you want to use to connect the outlets, actions, view etc to from the storyboard. This will work every time and cause you less grief than other ways of getting Xcode into Assistant Editor mode.

Could you add some pictures? I don’t really understand what you are trying to say.

Open your storyboard file.

Now old the option key, click on whateverFile.swift (the file you want to open)

This will automatically open it in the assistant editor

1 Like

Thanks a lot! It worked!

After a few classes about customizing, caches, and other stuff, my brain has turned into jello. At least I made a lot of progress to day!

I’m having another error when I ran my NewsApp. I had just did a bit of the navigation lesson in M06 L07, and I had just created the navigation ViewController or some thing like that.
Here is the error I got:

Thread 1: Exception: “Could not instantiate class named WKWebView because no class named WKWebView was found; the class needs to be defined in source code or linked in from a library (ensure the class is part of the correct target)”

I have the answer here. But you should make a separate question for this type of stuff and not post it in your journal feed.

Posting it in your journal, we can’t mark posts with a solution.

Also I would recommend using the search feature in discord, many of these kinds of questions have already been answered

https://codecrew.codewithchris.com/t/no-class-named-wkwebview/3542?u=mikaelacaron

Ok, thanks a lot Mikaela!

1 Like