Learn Courses My Dashboard

My code doesn't display answers

Hello,

my code simply won’t display answers in Quiz App. I’ve tried debugging and I’ve compared my code to Chris’ code. I don’t know what am I doing wrong, can someone please review my code? Thanks.
Download my code here: https://drive.google.com/file/d/1806LKP6tluRWHW_yb4Hs0tbzrak9TbVQ/view?usp=sharing

Upload your project to Google Drive or DropBox in preference and then share a link.

Downloading from mediaflare requires the user to create an account and then to be able to download the project as a multiple file download requires a premium account.

The other alternative, and probably what I should have suggested in my previous post, is to compress the entire project into a zip file (do that at the top level of the project) and upload that.

Updated the link. It’s a zip file now and you can download it via Google Drive.

Man, that was a tough one to find.

The initial issue was that the tag was not set on the label in storyboard. Since the label that is used to display the answers is identifiable by the tag assigned to it, in this case 1, with that in place and using breakpoints, the answers were being assigned in cellForRowAt.

Running the project on my simulator, the answers were still not visible so that puzzled me for a long time. I was checking that the label text color was set correctly and it was and then given that I had my simulator in dark mode I switched it to light mode (Shift + Command + A) and the text was now visible (label text is black in light mode).

So why wasn’t it visible in Dark mode?

I knew my version worked properly so I then started to look at the color settings for the View and the Label until I worked out what needed to be done to fix it.

The View in which the label is a child of needed a custom background color of white with a 50% Opacity. The alpha setting on yours for that View was set to 0.5 so by setting that back to 1 with the correct background color setting, it now looks fine.

Your project has been compressed and is available at the following link.

I had forgotten the process that Chris Ching had explained in the tutorial to build that screen UI so it was a little bit of trial and error to find the problem.

Good luck with the remainder of the course.

Thank you so much for your help :pray:!