Learn Courses My Dashboard

Not Seeing List of simulators

Hello,

I recently created a new xcode project and my simulators have all disappeared.

It is there if I open up an old project, but the entire list is not appearing on my current project.

Most of the advice I got online were to add the simulators or open the device window but I don’t have the add simulators button and my device and simulators window is blank even though I am selecting a simulator.

I am using code version 12.4 on macOS version 11.11.

I am attaching a bunch of photos below for reference.

Thanks for the help.

Try scrolling up

Had this happen to me a few times until I realized I was at the bottom of the list

The other possibility is that you started a mac app project instead of ios

Thanks for the reply inverse.

I tried scrolling up but it didn’t work as that was the only option

its also not a Mac project

I have seen a bunch of other people talk about this but for most of them they had the add simulator button or the simulator window is working

For me neither is working.

Is this the first project you have created with Xcode 12.4 or have the simulators suddenly stopped appearing?

I’m assuming you have rebooted your Mac after installing Xcode and that you have sufficient available disk space?

Thanks for the reply Chris.

I tried to reboot my Mac and it said that I can’t shut it down because I didn’t quit Xcode, then I tried to quit Xcode but the quit Xcode button was greyed out and cmd Q was not working either.

I then force quit Xcode and restarted my Mac and then clicked the add new scheme button which brought back all my simulators

1 Like