Learn Courses My Dashboard

Please Help! GIDSignInDelegate Not Found, Even though i imported GoogleSignIn

What does your Podfile look like?
Also just curious what’s your Xcode theme?

Here is the Podfile:

Uncomment the next line to define a global platform for your project

platform :ios, ‘14.0’

target ‘YouTube App’ do

Comment the next line if you don’t want to use dynamic frameworks

use_frameworks!

Pods for YouTube App

pod ‘Alamofire’
pod ‘GoogleSignIn’

end

Also the theme is custom

Thanks

You could instead try Swift Package Manager because it’s easier

But even if you clean the build folder and delete derived data and run again, you still get the error?

I cleaned the build folder but im not sure what derbies data is?

Derived data, sorry typo; open Xcode preferences under general is a tab for location

There’s an arrow to the path for derived data and click on that and it opens a folder called DerivedData

Delete that and rebuild the project

It’s a directory where Xcode stuff is cached, so if you’ve never deleted it before it’ll be pretty big

Hi, still getting the error.

How do i do it with Swift Package?

This video may help

Hi, i deleted coca pods from my project but i dont have the right urls for Alamofire and Google Sign in.

I actually found the urls for both of them and successfully imported both but am still getting the issue

And you’ve deleted DerivedData folder?
And tried to restart your computer?

Hi, i yes i have but i dont think its any of that because if i open the solution file it has GIDSignInDelegate. I must have done something wrong but am not sure what.
Do you have any idea of what i might have done wrong?

Which packages did you add with SPM?

Alamofire and GoogleSignIn

Which versions of each did you install?
GoogleSignIn looks like it has an issue with 6.0