Preview problems


Just starting war card and ran into a issue with preview. Not sure what happened but I am now not able to preview anything. The error says

Failed to launch app in reasonable time.

Running 2017 Core i5 iMac with 8 GM of memory

Using Xcode version 12.3

Tried starting new project with new name. Tried clean the build and clean the build folder.

Any ideas?

I have the same problem since updating my Xcode to 12.3 and my macOS from Catalina to Big Sur.
It doesn’t matter if I run an older Project or a new project with only the “hello world” in it.

But when I use the simulator, the simulator works fine. Only the preview is like a book with 7 seals.

MacBook Air 2014 with 4GB and 128HDD.

Post your code for ContentView.swift so that we can see what you are trying to do.

Hey Chris,

Thanks for replying. ContentView.swift is from the beginning of the project. It says”Hello World”.

That’s odd. Have you tried closing Xcode and rebooting your Mac?

That changes nothing. But I tried Xcode on a MacBook Air M1. There everything works fine.

But I got a solution for my MacBook. When I uncheck “tests” and don’t make a git on my Mac it works as well.

So it’s time for a new MacBook :joy: