Learn Courses My Dashboard

Problem while building custom login demo

hello my friends

some problems while building custom login demo at the ( authentication tutorial 2020 ) video

i faced some problems and i solved some of them but at the middle of the video mr chris had already forgot to put these pods :

pod ‘firebase/firstore’

pod firebase/core’

i installed it successfully but after coming back to the project , i wanted to re-build the project but it doesn’t worked , after i checked it i saw that an error occured in the ( int128.h ) page at the 1081 breakpoint .

and it wasn’t letting me to re-build the project.

hope you know the solution

and thank you so much

did you successfully “pod install” both new pods? you need to do the pod install again if you want to make any changes to the project…
also if you added a new pod its ideal to do a “clean” before you rebuild since theres some old temporary files that may cause conflict

thank you for answering my friend
but what do you mean by clean the file .
can you please tell me how to clean it because i am a beginner and i dont really know what do u mean by saying ,clean,
thanks

and one more thing my friend the pods have successfully installed , but the problem is i cant rebuild the project , it is kind of weird while you are coding and you wanna rebuild or run your project and its not working and i have already re-installed the pods , and i havent made any changes to the project , i just forgot to install the firbase and core pods i installed it at the middle of the project .
as i said in the first comment it was erroring that ( ‘absl/numeric/int128_have_intrinsic.inc’ file not found )

thanks for help

it would be ideal to exit the app and load it again to prevent unusual behavior, have you tried installing cocoapods via terminal? check out our article and see if it can help CocoaPods Tutorial using Swift and Xcode

the clean just right below the build

just go to “project → clean build folder”

thank you so much for answering but i have tried every one of this but still not working

are you perhaps using some older versions of the other firebase pods for your project? can you show your pod file?

sure!! why not , thanks
Screen Shot 2021-05-26 at 6.04.25 PM

hmm not really sure whats wrong, maybe try adding

pod ‘Firebase/Database’

if it helps

and if you haven’t already please perform the clean

hello my friend , sorry for taking your time i tried it but sadly still the same
no problem my friend if you don’t know the solution don’t waste your time with me but tell me what do you suggest me to do ?

thanks
NOTE : i also cleaned it but it is the same

can you upload your project and put it in github or dropbox so we can run it on our side?

can you please link a video for me about how to use github
because i have never used it before and i dont know how to send it through it .

and will all peoples be able to download my xcode project or only you can ?
thanks