Rsync command & filepath problem

Hi, can anyone tell me how to handle spaces in a directory path when writing a zsh script? The code below works when there is no space in the folder name and script. When I introduce a space though I’m struggling to get terminal to see the directory. I have tried quotes. I have tried escaping the space with a backslash, as in the code below. Nothing has worked so far. I could just remove the spaces, but it would be good to know how to write the code so that it handles space in folder name.

source_folder="/Users/rg/Documents/Test 1/"

destination_folder="/Users/rg/Documents/Test 2/"

rsync -av --dry-run $source_folder $destination_folder

You are asking the question in the wrong forum. This group is focussed entirely on iOS Development so you would be best advised ask your question on a Unix or Linux forum.

Okay. I just thought it was a pretty simple thing and would be of interest in spite of it not strictly being Swift. It is an interesting thing about the Mac OS and the way it handles paths in the terminal.