Screen Size For iPhone 11 Pro Is not Working

Hello Mr.Chris

I was Going through your videos and trying to do the same thing on Lesson 4 ,I am facing problem on screen Orintaion and Screen zises for iPhone 11 Pro ,

please help me rectify it ,

I am not able to. make the background image or app interface with compatible with different screen size ?

Best Regards ,

Usman CP

Hi @usmancp08

Which version of Xcode are you using?
Also, if you describe step by. step or upload some pictures, it might be easier to help you here.

I’m having the same problem . I can’t fit the background on the entire screen, I’m using xcode 11.
Thank you

Hi @Maroung13

You have to make sure that you select the “View” and not the “Safe Area” using the little arrow on the right of the drop-down, and unctick the “Constrain to margins” option (hidden by the popup on my screenshot below)

Capture d’écran 2020-05-08 à 20.16.48

That should resolve your problem.

@usmancp08 - I hope this is what you are looking for, and to answer your question - it will set the background image to complete the full screen automatically to all Apple devices sizes!

Thank you for your reply, but this doesn’t solve the problem in xcode 11 ,I don’t know why.
I selected “View” and unticked the “Constrains to margins”

I have tried few times to check and I think you have to follow this order:

  • Make sure all constraints for the background have been deleted
  • Untick the “Constrains to margins” FIRST
  • Select the “View” under the menu and THEN set to 0
  • Repeat for all borders
  • Apply the constraints

If it doesn’t work, it is probably that you are not referring to the superview (border of the screen) but another element… I think Chris is using a VStack in this exercise - Is it not possible that your UIImageView has been added to your UIStackView instead of being in the background?

You can also verify this in the size inspector of the UIImageView:

Capture d’écran 2020-05-08 à 21.02.32


In fact, I think you are experiencing the same problem than on this thread:

This page is private or does not exist anymore, but I found a solution : I changed all of these to Superview(in the image below).
Thank you so much for your replies
Screen Shot 2020-05-09 at 10.43.40 AM

Version 11.4 beta 2

Sorry for the link, it has been referring to the paid area…

To resume, it is a problem in the old version of Xcode and Beta versions (you probably have to update to latest version - actually Version 11.4.1 (11E503a)).

When you are entering the four “0”, it removes them and replace by “Default” (nil):

You have selected “Aspect FIT” instead of “Aspect FILL” (right column)

Its Done ,Thank you So much , Best and Fast Support ! Appreciated :+1:t2::v:t2:

1 Like

Please mark as answered, it might help future people here