Learn Courses My Dashboard

Simulator not launching instead getting message

I had no problem running the simulator before but tried to do it this morning and its not launching. It seems like it is in the background but I’m not seeing it. I just see these messages come up in the Output section

2022-04-02 06:42:06.025427-0700 fruggienew[19733:826878] 8.7.0 - [Firebase/Analytics][I-ACS023007] Analytics v.8.7.0 started

2022-04-02 06:42:06.059688-0700 fruggienew[19733:826878] 8.7.0 - [Firebase/Analytics][I-ACS023008] To enable debug logging set the following application argument: -FIRAnalyticsDebugEnabled (see http://goo.gl/RfcP7r)

2022-04-02 06:42:06.147968-0700 fruggienew[19733:826878] [boringssl] boringssl_metrics_log_metric_block_invoke(153) Failed to log metrics

2022-04-02 06:42:06.213679-0700 fruggienew[19733:826877] [boringssl] boringssl_metrics_log_metric_block_invoke(153) Failed to log metrics

2022-04-02 06:42:07.023831-0700 fruggienew[19733:826877] 8.7.0 - [Firebase/Analytics][I-ACS800023] No pending snapshot to activate. SDK name: app_measurement

2022-04-02 06:42:08.120113-0700 fruggienew[19733:826877] 8.7.0 - [Firebase/Analytics][I-ACS023012] Analytics collection enabled

2022-04-02 06:42:08.122039-0700 fruggienew[19733:826877] 8.7.0 - [Firebase/Analytics][I-ACS023220] Analytics screen reporting is enabled. Call +[FIRAnalytics logEventWithName:FIREventScreenView parameters:] to log a screen view event. To disable automatic screen reporting, set the flag FirebaseAutomaticScreenReportingEnabled to NO (boolean) in the Info.plist

2022-04-02 06:42:20.768485-0700 fruggienew[19733:826886] [boringssl] boringssl_metrics_log_metric_block_invoke(153) Failed to log metrics

2022-04-02 06:42:20.971469-0700 fruggienew[19733:826901] [boringssl] boringssl_metrics_log_metric_block_invoke(153) Failed to log metrics

Cleaning the project and deleting derived data doesn’t do anything?

Most of these logs look related to normal Firebase logging

How do I do that?

To clean the project means cleaning some of the logs from the build folder.
Press Cmd + Shift + K or Product > Clean Build Folder

Also delete derived data does something similar, but it holders different logs

Type Command +, or go to File > Preferences

Click Locations > under Derived Data there’s an arrow in small text to the derived data folder on your computer.
Click that arrow, and delete the Derived Data folder

Rebuild / run your project

If you have Swift Packages, you’ll need to reload them

Thank you! Just cleaned the project. It still did the same thing. Its building the project but when its trying to attach (when trying to run the simulator) thats when I’m getting those messages


I am getting a bunch of gRPC-Core issues, but I am new to all of this so I don’t know how to approach it.

If you create a brand new project, does that run?

(I’m trying to isolate if it’s Xcode, or your project that’s having the issue)

I tried to run an old project that I had but that one had constraint issues thats why it didn’t open up, it didn’t have the same output messages

But with a brand new project, what happens?

2022-04-03 17:52:19.916214-0700 random test[27306:1013057] [LayoutConstraints] Unable to simultaneously satisfy constraints.

Probably at least one of the constraints in the following list is one you don’t want.

Try this:

(1) look at each constraint and try to figure out which you don’t expect;

(2) find the code that added the unwanted constraint or constraints and fix it.

(

"<NSLayoutConstraint:0x600001efd540 UILayoutGuide:0x6000004eeca0’UIViewSafeAreaLayoutGuide’.bottom == UIImageView:0x7fa89a814440.bottom + 137 (active)>",

"<NSLayoutConstraint:0x600001eee3f0 UIButton:0x7fa89a8137f0.top == UILayoutGuide:0x6000004eeca0’UIViewSafeAreaLayoutGuide’.top + 433 (active)>",

"<NSLayoutConstraint:0x600001eedc70 V:[UIButton:0x7fa89a8137f0]-(89)-[UIImageView:0x7fa89a814440] (active)>",

"<NSLayoutConstraint:0x600001efd7c0 ‘UIView-Encapsulated-Layout-Height’ UIView:0x7fa89ab058a0.height == 568 (active)>",

"<NSLayoutConstraint:0x600001ef4dc0 ‘UIViewSafeAreaLayoutGuide-bottom’ V:[UILayoutGuide:0x6000004eeca0’UIViewSafeAreaLayoutGuide’]-(0)-| (active, names: ‘|’:UIView:0x7fa89ab058a0 )>",

"<NSLayoutConstraint:0x600001eedd60 ‘UIViewSafeAreaLayoutGuide-top’ V:|-(20)-[UILayoutGuide:0x6000004eeca0’UIViewSafeAreaLayoutGuide’] (active, names: ‘|’:UIView:0x7fa89ab058a0 )>"

)

Will attempt to recover by breaking constraint

<NSLayoutConstraint:0x600001eedc70 V:[UIButton:0x7fa89a8137f0]-(89)-[UIImageView:0x7fa89a814440] (active)>

Make a symbolic breakpoint at UIViewAlertForUnsatisfiableConstraints to catch this in the debugger.

The methods in the UIConstraintBasedLayoutDebugging category on UIView listed in <UIKitCore/UIView.h> may also be helpful.

this is what I am getting now
all I’ve added is an image with a button under it

But your project is building now?

This is a constraint error use https://wtfautolayout.com to learn more about the error message and what it’s saying. You’ve likely done the constraints wrong somehow

it is building but when it comes to the “attaching” part and then when the simulator would pop up …thats when its giving me the original message and the simulator does not pop up or open.

And when you build a brand new project, without changing any of the code, what happens?

Now there is no error or output message because I didn’t change any code or put anything, but it builds it and it says running but the simulator isn’t popping up

Okay so that would mean that there’s some issue with your Xcode / simulator
Not specific to your project

In the simulator, click the menu bar to: Device > Erase All Content and Settings

Which deletes everything on your simulator, once that’s completed, then try to run your project again

it’s greyed out, it won’t let me click on it

On the menu bar I tried to click “open simulator” and I got this message Screen Shot 2022-04-04 at 9.35.01 PM

Try opening the simulator app directly, like from Applications

I tried that too but it didn’t work. But for some reason in the middle of the night my computer restarted because of a problem and now its working again. The simulator is popping up again, I am getting those output messages still but at least the simulator is coming up