The Database Course Module 3 Lesson 2

I’m getting this error when I try to build my project after installing all the required pods for the PhotoApp lesson.

Below are the attempts I tried:

  1. I actually deleted and recreated the “PhotoApp” project a couple times in Xcode and went through the project setup step by step as shown in Module 3 lesson 2 Setup up to around 6:50. Still got the same errors.

  2. in Podfile, I have also tried setting the pod version to what’s specified in the lesson video(pod ‘FirebaseUI/Auth’, ‘5.0.0’), but it lead to another dependency error.

  3. I tried searching Google to see if I can self-fix this issue, and found this post on Stackoverflow.

This person is having the same exact error that I have, but no solution/answer has been posted as this question had been asked only 2 days ago.

Am I the first one to have this type of error in this lesson?


In the podfile like shown from stack overflow, try changing the iOS version from 9.0 to 10.0?

Not sure if this will help, but I’d try that, and also updating the pods

try to clean build files first

Product -> clean build folder

then try to rebuild your project to see if it works

Hello Mikaela,

Thanks for your input, but changing the iOS version from 9.0 to 10.0 and uncommenting that line in podfile didn’t fix the issue. 34%20PM

I’ve also ran “pod update” command in the terminal inside the PhotoApp directory after “pod install”, but this error didn’t go away. If I ran “pod install” with the podfile above, it should install the latest pods anyway so update shouldn’t be necessary correct??

Hello Francis,

Cleaning build files didn’t fix the issue…
but still thanks for providing me with one possible solution that I can try next time xcode project build fails!

Hey! I had the “exact” same problem. I tried many things and continued to get similar errors.

I made it work by updating Xcode to the most recent version, building a new project from scratch and then following the steps on the Firebase website. The steps are basically the same except for a few small differences with pods you need to include. ( Chris has a recent Firebase tutorial on Youtube that is only a few months old, do this tutorial and you will not have problems )

I will mention that once you get the authentication sign-up working, during the next few lessons of the PhotoApp module you may run into more issues if you follow Chris’s lessons step by step.