Learn Courses My Dashboard

Updated to iOS 16.4 and having Xcode issues

I updated to iOS 16.4 yesterday. I have been using Xcode 14.3 with no issues.

Unfortunately now I can not open Xcode. It just keeps giving me the ‘not responding’ pin wheel. Sometime it will open and then it will not respond. I have deleted Xcode and reinstalled it. I also tried installing 14.2 but that is not compatible with Ventura 13.4.

Anyone else have this issue and know a fix? Thanks.

Below is the report:

Date/Time: 2023-05-19 14:58:45.221 -0500
End time: 2023-05-19 15:04:34.410 -0500
OS Version: macOS 13.4 (Build 22F66)
Architecture: arm64e
Report Version: 40
Incident Identifier: C3FF9493-94C6-4212-B7E2-F50BB5D374D0

Data Source: Stackshots
Shared Cache: 7D9FAA84-5C6B-3EF4-9379-FABA64346673 slid base address 0x1a129c000, slide 0x2129c000 (System Primary)
Shared Cache: ECF2CD57-50B4-3705-BEA9-ED0732E5EBD8 slid base address 0x1f129c000, slide 0x7129c000 (DriverKit)
Shared Cache: 9BDF650C-7FC0-3DE1-BAC4-8535AEA9B6AA slid base address 0x7ff809fc8000, slide 0x9fc8000 (Rosetta)

Command: Xcode
Path: /Applications/Xcode14.3.app/Contents/MacOS/Xcode
Identifier: com.apple.dt.Xcode
Version: 14.3 (21812)
Build Version: 3
Product Build Version: 14E222b
Project Name: IDEFrameworks
Source Version: 21812000000000000
Team ID: 59GAB85EFG
App Item ID: 497799835
App External ID: 855820377
Is First Party: Yes
Architecture: arm64
Parent: launchd [1]
PID: 1122
Time Since Fork: 356s

Event: hang
Duration: 349.19s
Duration Sampled: 1.90s (process was unresponsive for 347 seconds before sampling)
Steps: 19 (100ms sampling interval)

Hardware model: Mac14,7
Active cpus: 8
HW page size: 16384
VM page size: 16384

Time Since Boot: 777s
Time Awake Since Boot: 777s
Time Since Wake: n/a (machine hasn’t slept)

Fan speed: 0 rpm
Total CPU Time: 4.129s (9.9G cycles, 13.7G instructions, 0.72c/i)
Advisory levels: Battery → 3, User → 2, ThermalPressure → 0, Combined → 2
Free disk space: 339.28 GB/460.43 GB, low space threshold 3072 MB
Vnodes Available: 58.73% (70983/120870)

Preferred User Language: en-US
Country Code: US
Keyboards: U.S.
OS Cryptex File Extents: 18

After you install Xcode you should re-boot your Mac.

When you then open Xcode, allow it to install additional software.

Restart your Mac and then launch Xcode again.

See how you glow and report the outcome in a reply.

That second reboot worked! Thank you sir.


Good to hear Shawn.