Learn Courses My Dashboard

Vapor not working

So i installed home brew and that was successful and i installed vapor and it said it was successful but when i run the vapor --help command it says zsh: command not found: vapor.

If you type brew list do you see Vapor listed there?

Try typing brew update && brew upgrade to update HomeBrew and Vapor (even though you just installed them)

Then try vapor —help


Here is what im getting back.

Use two hyphens


Just tired same thing

And quitting terminal and opening it again doesn’t do anything?

This is odd.

Maybe run these commands (which is uninstalling it and trying to re-install it again)

brew uninstall vapor && brew untap vapor/tap && brew install vapor


I get this error when i try to uninstall.

Im on a m1 mac can that be the issue?

The Vapor tap I’m not surprised about because that’s an old version of Vapor (and cause you downloaded new you wouldn’t have it)

Just do brew uninstall vapor

No I have an M1 and was able to install it with HomeBrew, and had no issues (but at the time of recording the video I was on my Intel machine)

I can’t seem to uninstall it because i think i dont have it (Every time i run any command with Vapor in it it says Error: Cask ‘vapor’ is not installed witch i assume means i dont have) but its really confusing because it said the the install was successful.

Not sure what im doing wrong here.

That’s strange. I don’t think you’re doing anything wrong, it sounds like some issue with your computer.

Try to reinstall HomeBrew

Hi, i think it worked. This is what i got back.

Perfect!! :heart_eyes: yes you should get back the different commands you can run (exactly like you showed)

What changed? Can you post what you did and mark it as the solution, so that others can find it if they run into the same thing

I just uninstalled HomeBrew and installed it again and then installed Vapor and it worked.

I dont think i did anything different, but now it works.

1 Like