Xcode 12.1 layout issue: info.plist columns

For some reason I cannot adjust the width of my Type and Value columns in the info.plist. Does anyone know if this fixable, or perhaps it is a bug?


Hover your cursor on the thin bar at the top of the column separator and it will change to a resizing indicator. Click and drag the column left or right to suit your needs.

Thanks for that. But that is the issue. When I try to resize the type or value column it is immovable. The Key column can be resized no probs, but the other two are locked tight.

I’m curious to know how much room you need?

If you need the entire screen space to view the Info.plist file then hide the Navigator panel (on the left) and the Inspector panel (on the right) to give you more space.

My problem is that the Value panel is so narrow that I cannot read it. For example, for the first entry in your screen shot all I’m able to view is $(DE.

The column will not widen. There’s no problem with the width of the info.plist as a whole.

can you narrow the Key column?

Hi, Greg.

Yes, the key column is fine. It’s the other two columns that aren’t working. The slider symbol doesn’t pop when you hover the mouse over columns edge.


Can you provide a screen capture of what you are seeing (the entire Xcode window). None of that makes any sense to me at all so hopefully a screenshot might help.

I must be explaining it poorly. Simply put, the type and value columns will not resize. There’s plenty of room to resize them, but they’re inactive in regards to changing their width.

I understood what you were getting at but it wasn’t making sense that you were not able to resize or move that column. I just wanted to see your entire Xcode window (I really meant the entire screen much like the sample I provided earlier above) so that maybe I could pick up on what might be the issue.

What version of Xcode are you using?

I’m using version: Version 12.1 (12A7403)

Here’s a full screenshot.

That’s intresting. I note that even though you have the Info.plist selected in the Navigator panel there is no information listed on the Inspector Panel like the screen shot below.

I assume that you have tried all of the obvious remedies like shutting down Xcode and then re-opening it OR restarting your Mac OR even tried downloading the Xcode_12.1.xip file from the Developer site and reinstalling it.

You need a Developer account to access the link above.

I’m not sure why the Inspector panel is blank. I think it’s just the way it ended up after I’d been clicking a few things - it does actually work as normal. Yes, I’ve tried everything that you’ve mentioned, bar downloading the .xip file and reinstallling. It takes so damn long (literally up to four or five hours) to download from the apple developer site that I’m reluctant to do it. There is a limit on my data too, and I’m close to the limit, after which it costs me $10.00 per GB. That would be $110.00 to download Xcode, so I’ll wait until my data ticks over and then update it when I update to Big Sur. I can live with the bug for now, so I’ll hold tight. Thanks for taking a look at it.

I have the same problem. Using Xcode 12.1.

I think it must be a bug. If it has been reported to Apple then no doubt it will have been fixed in the latest update.

I doubt that it is a bug. Something has gone pear shaped with your Xcode installation and you need to reinstall it.

After upgrading to Big Sur and updating to the latest Xcode I still cannot resize the two columns. But luckily the values column is sized wide enough to read after the update.