Learn Courses My Dashboard

Xcode 12.4 simulator issue

When I am trying to run the app in simulator getting services not available. That is API is not calling in simulator.

But it is working fine in device. I am using xcode 12.4 and tried to run in iPhone 12 14.3

I have tried with couple of solutions:
1.plist - Allow Arbitrary to YES
2.Enabled HTTP services in simulator
3.erase all contents in simulator
4. Quited xcode and simulator
5.restart the system
6.Disabled proxies in system
7.Wifi connection is strong in my system

With these my issue is not resolved.
If anybody knows, please help me to solve this.
I really want to run the app in simulator iPhone 12 14.3.
I am in a critical situation!

Thanks in advance.

What exactly is it you are trying to do? You’ve explained what you’ve done to try and solve your problem but haven’t really explained what your problem is.

What happens in the simulator? Does your app crash? Do you get an error? Unexpected results? We need some info if we’re to help.

Getting API services unavailable while I am trying to run the app in simulator.
I could not able to login to the app.

But when I try to run the app in device. I can able to login to the app.

I am using xcode 12.4

Try cleaning the project Cmd + Shift + K and deleting the derived data folder

I did this.
Still facing the same issue.

What API are you requesting?
Can you show your code??
(Be sure to not show your API key)

Please post it as text, not a screenshot. You can do this by placing three backticks on the line before your code and three backticks on the line after your code so that it will be formatted properly. You can also highlight an entire code block and click the </> button on the toolbar to wrap the block for you.

This makes it far easier to read and also makes it easier for other posters to copy/paste the code in order to test solutions and such.

Ok… I will send.

Befor that I want to mention this
In simulator, safari is not working. Showing as server not found.

But wifi connected in system.

That’s probably why.

Did you ever change the network settings in Xcode to simulate a slow or stopped network?

Here’s a video on what I’m talking about. Make sure the network is enabled