Learn Courses My Dashboard

Xcode 12.5 and Catalina

Hello.

Has anyone overcome the problem of not being able to install Xcode 12.5 on an iMac running Catalina as I now cannot use my iOS 14.5 devices as live simulators?

Xcode 12.5 requires MacOS Big Sur. Is there a reason that you don’t want to install Big Sur?

Hi Chris
Thanks for your reply.
I forgot to mention that my iMac is late 2013 and so I cannot install Big Sur.
I don’t want to buy a new iMac at this stage and was hoping there was a way around he Xcode 12.5 issue.
Regards, Alan

Have you taken a look at Xcode Releases?

Thank you, yes I have.

possible workaround that might also still work would be similar to what we have here

so try doing similar steps but for xcode12.5 instead of xcode 10.2.1 in this hack

Hi Francis.

Thank you for your help and suggestion. Unfortunately, I don’t have a Developer account as yet and am therefore unable to download the latest version of Xcode as per the instructions above. I may be able to download from a third party site but I don’t trust these sites. Thanks again, Alan

No need for a developer account… As long as you have an apple account its the same thing

When I log in with my Apple Id, I get a dialog titled 'Need assistance with accessing your developer account?" and a form to submit and that’s as far as I get. It would appear that I do need a developer account.

hmm thats weird… then just try making a new developer account then it should be fairly easy, I don’t remember even going though that process myself at all…

Hi Francis

Just thought I’d let you know that I’ve signed up for an Apple Developer account and have tried to install Xcode 13 using the Xcode 10.2.1 instructions you told me about but unfortunately they didn’t work.
Someone posted in the notes about plist files being cached that could explain why it hasn’t worked.

However, I have bigger problem now not being able to install Big Sur on my late 2013 iMac.

I intend now to do another post about the safety of applying a patcher to install Big Sur (i.e. on an unsupported Mac).

Thanks again for your help though.

macOS 10.15.7 and Xcode 12.4

I’m on the highest version of each for my mac