Xcode 12 problem with simulator and canvas

Hello everyone, I would like to ask u about one problem with XCode, maybe someone can help me. I have IMac i5, 3GHZ 6core, 8gb Ram. Recently i had XCode 11 and I never had problems with it. So, after I updated my Mac to Catalina 10.15.7 i also updated XCode to 12 version and now it works very slow, doesn’t show canvas and simulator correctly. It works a little bit better after command (sudo xcrun simctl shutdown all && sudo xcrun simctl erase all). Someone knows what is this problem and how to fix it? Thank u

Hi Алина,

Welcome to the Code Crew community.

The first thing you should do after an Xcode update is to restart your Mac. This ensures that any updated files are reloaded at startup.

The other suggestion is to run “Disk Utility” and select “First Aid” for both volumes. This may take some time on the larger Volume so have a cup of coffee or go for a walk.

Thank u, now it’s work!)

1 Like

Fantastic. Happy coding.
:clap:

Hello again)
Today i had the same problem…I don’t know why, becouse yesterday it worked. So, I reinstalled Catalina and Xcode, and it’s still doesn’t work😭

Your iMac might be struggling because it only has 8Gb of RAM or you might not have enough free space on your HDD. If you close all your applications and only have Xcode running, does Xcode work OK?

Hi, problem is that i have only Xcode, I bought this computer only for codding 2 month ago, and with Xcode 11 never had a problem, problems started when I downloaded Catalina 10.15.7 and Xcode 12, and now if I download older Xcode version its also doesn’t work:(

Did you try my other suggestion to use Disk Utilities and run ‘First Aid’?

My thinking behind that suggestion is that there might be a permissions issue.

I noticed that when i open system monitoring there are a lot of strange activity like “news today”, “spring board” “news tag” ecc, which using a lot of memory ram, I don’t know what is this, maybe this is the problem🧐

But now it work (canvas and simulator), so one day it works, another day no, :exploding_head:

That might certainly have something to do with it although I don’t know how to stop that. The other thing that your Mac will be doing after you reloaded the Operating System is regenerating Spotlight which is a database that allows faster searching on your Mac. That consumes a lot of time until it has completed that task.

One other thing that you could try is to reset the PRAM (Parameter Random Access Memory) which stores system settings.

The process is described here:

Abnormal numbers of identical process, but when I stopped them it works ok.

Thank u for your help:)

1 Like