Learn Courses My Dashboard

Xcode and MacOS Monterey

So by this time are most developers running Xcode 13.x and Monterey?

I have started the one-year-old “2021 SwiftUI Tutorial for Beginners” and lessons 3 and 4 cause my MacBook Pro to shut down without warnings. I tried going back to Xcode 12.x but Monterey wouldn’t let me do that.

Problems started with app store Xcode 13.4.1 so now I have the 14 beta. This got past the shut down problem in Lesson 3, but it is back now in lesson 4. This macbook has 16GB memory and about 200GB free drive space, was recently wiped and has a new battery.

I have a lot of coding experience. Xcode and Swift are SO NICE! Amazing! Such a clear and helpful IDE, kinda like a Fisher-Price toy next to what we had since the 1980s.

The Xcode 14 beta has been causing issues with Xcode 13 on people’s machines (is what I’ve heard)

Which I think is insane, but I have heard of that happening

Definitely always use the latest Xcode, so 13.4.1 right now, and try maybe uninstalling the beta, unless you really need it for something

Sorry for the hassle, folks. I will simply move my development efforts to my desktop, a 27 inch Retina iMac with 24GB mem, two 2TB drives, running Big Sur MacOS 11.5. Downloading Xcode to it now.

Thanks for thinking about this issue. I was given the MacBook Pro as a gift, and figured that app dev might be a good use for it.

13.4.1 is what originally caused the problems. But Thanks!

As far as my original question: Is Xcode 13.4.1 working well for systems running MacOS Monterey?

Xcode 13.4.1 is working fine. You may need to reinstall it if you are having issues.

Have you tried creating a brand new project rather than use the existing one you created? It could be that the project has somehow gotten corrupted.

I think that must have been it. File corruption. I normally don’t think of that, and I have not been bothered much by that since my first Macintosh computer in June, 1984.
I’ve always thought “this is one reason I use a Mac.”

But Xcode 13.4.1 now seems to be fine on this laptop running Monterey.
I deleted xcode 14 beta, reinstalled 13.4.1, and Airdropped the uitest project that is trouble-free from my desktop iMac. It runs now …

Thanks!!!