Learn Courses My Dashboard

Xcode App Error

Hi guys, I am building an app. I ran into an error and I am not quite sure exactly what it means.

/Users/prathamhebbar/Desktop/Custom Apps/Palendar/Pods/GoogleUtilities/GoogleUtilities/AppDelegateSwizzler/Public/GoogleUtilities/GULApplication.h: No such file or directory

That’s an error with I’m guessing Firebase that you’re trying to use?

Try to clean the project Cmd + Shift + K

If that doesn’t work try updated the pods

seems you are not familiar with a project with cocoapods yet, i suggest checking out this article to be familiar with it CocoaPods Tutorial using Swift and Xcode

Thank you for the suggestion! I tried doing that and it did not work out.

Thank you so much! I will definitely look it over!

How did the error start? What we’re you doing when the error appeared?

I think the reason everything went downhill is that I had installed the firebase analytics pod but upon creating my firebase project, I had not enabled analytics. So I removed that firebase analytics pod from my Xcode project.

is your app working fine now?

Sorry for not replying to your message! My app is unfortunately not working fine!

Upon further investigation, I am running into this error.

/Users/prathamhebbar/Desktop/Custom Apps/Palendars/Palendars.xcodeproj The linked framework ‘Pods_Palendars.framework’ is missing one or more architectures required by this target: x86_64.

Can you please tell me how I can fix this?

Thank you so much!

@Dumby

Pratham,

What are the pods that you specified in your Podfile?

Hi Chris,

Here are the pods that I specified in my Podfile:

pod ‘Firebase/Firestore’
pod ‘Firebase/Analytics’
pod ‘Firebase/Auth’
pod ‘Firebase/Core’

Can you please tell me if I am doing anything wrong with installing the pods or with the xcode workspace?

Seems like you have the right pods. You will get some errors when you build the project because Google have been lazy and not updated the pod definitions in line with the requirements by Apple for the minimum deployment target. As long as you update the settings that Xcode advises you to do then you should be OK.

Also make sure that after you install the pods that you open the project via your ProjectName.xcworkspace file rather than via ProjectName.xcodeproj

Hi Chris,

Thank you so much for getting back to me! I have been opening the .xcworkspace file. However, when I open the .xcworkspace file I still get that error namely this one:

/Users/prathamhebbar/Desktop/Custom Apps/Palendars/Palendars.xcodeproj The linked framework ‘Pods_Palendars.framework’ is missing one or more architectures required by this target: x86_64.

Also, can you please specify the settings that Xcode wants me to update?

did you perhaps make your app settings be an old ios version or something? whats the target ios version thats supposed to run?

i suppose it wouldn’t hunt to do a clean so you can make sure old unnecessary files are not conflicting

Thank you so much for the suggestions and advice!

But however, I don’t think I made my app settings an old ios version. I think the target is arm64 since I have an M1 Mac.

Since you have a Mac with an M1 processor, before you installed pods for any project, the question is:

When you originally installed cocoapods on your M1 Mac did you have any errors in the installation process and have you resolved all the errors so that cocoapods was installed successfully?

When I originally installed cocoa pods on my M1 Mac, I don’t think I had any errors in the installation process. I think I have resolved all the errors for now.

Thank you so much for getting back to me! I appreciate your time very much!

Upon further investigation, I think I have resolved the issues in my app and I think my app is compiling fine.

Thank you guys so much for your input and advice! Your time is very much appreciated!