Learn Courses My Dashboard

Xcode default new project error

Hi all,

I’m new here an downloaded Xcode 13.4.1 and i got errors immediately with a new project. So I downloaded 13.3.1 thinking it would be more stable but I still get errors when starting a new project. I have deleted xcode 3 times, restarted, changed saving directories and am still having issues. I can’t find anything else on Apple’s support, developer communities or even google that address this new issue.


Being new to this I have no idea how the default file is full of errors. My questions are:

Is there a way to correct this code?

If not, is there a different, more stable Xcode I can use (or is it too late)?

@jc11

Hi Jeremy,

Welcome to the community.

Seems a little odd that a new project would give you these errors straight up without having added any code.

What Mac are you using and how much free disk space do you have?

Did you have a previous working copy of Xcode before you installed Xcode v13.4.1?

Hi Chris! Yes, I did have Xcode previously installed (can’t remember the version, tho). I was following along with the YouTube lessons then thought I should sign up for the full CWC+ experience and update Xcode at the same time. I guess I should have left it alone.

I’m using an M1 macMini running Monterey with over 50gb space on the hd.

Thanks for any help.

@jc11

That’s odd. I have an M1 also with no issues.

I doubt there is an issue with Xcode itself, rather I suspect that there has been an installation problem although I have never encountered any in my case. When you did initially launch Xcode after you installed it, did it present a dialog to advise that it needed to install additional packages and did you allow that to take place?

Don’t name your entire project lesson - 04 challenge

Make a folder with that name and instead name your project 04challenge or something simple

You should use the latest version of Xcode

Thank you. I will give that a try and let you know if that was it.

@mikaelacaron Yes, it seems the file name was the cause of the errors. Thank you for the help.

1 Like

Ah yes, the hyphen - in the name was the killer. Just tried that out and it sure hates it.

It doesn’t hate hyphens, usually it changes to underscores

But having so many spaces and hyphens is probably what it was

As an exercise, create a project with the name “my - app” and the error will show up in the view conforming to App (where @main is).

It’s the spaces with the hyphen.

my-app there’s no issues

my - app there’s issues

Either way I would not recommend that you name a project with spaces or hyphens anyway even though it copes with a name with several spaces.

Wow! Thank you both for troubleshooting that out. Impressive work.

Glad to know it was just the naming convention that confuses a multi-trillion dollar publishing software. :smiley: