Xcode Minimum iMac Reqs?

Complete Newb - Downloaded Xcode to follow Chris’s beginner tutorial but Xcode is just stuck trying to “Prepare iPhone simulator”/“Building Demo for Previews”

Maybe this iMac just isn’t up to the task?

  • 3 GHz 6-core i5
  • 8GB DDR4
  • 963GB available


Can you share the code you have for the View in which the preview is not responding. It sounds to me that there might be a modifier error.

Chris - The code is just the stock “Hello World” base. I haven’t got to actually start coding anything. Seems like Xcode is just too much for this iMac to handle. Although that seems odd considering there are other people using it on older Macs than this.

What version of macOS do you have on your iMac?
When you installed Xcode and opened it for the first time did you allow it to install the additional components which adds simulators?
Did you reboot your Mac after the installation was complete?

8Gb of RAM is not very much these days and I would have thought that you would need 16Gb at the very least. The entire Xcode application consumes close to 30Gb of disk space when installed and is memory hungry when runnng. If you don’t have sufficient RAM the operating system will spend a lot of time “paging” memory.

How much free disk space do you have?

Sanoma 14.0/ Yes, the “App” component/ I’ve rebooted/ System shows 952 GB available.

I brought up the Activity Monitor and the daemon “diagnosticd” was pegging well over 100% usage. I’m very much a beginner, but it looks like others have posted about this and somehow error messages are flooding the system log which leads to a lot of CPU usage. IDK if that’s relevant or not.

If you are not running Xcode, do you still get the same CPU usage from that daemon?

It would be useful to know what Application is the culprit.

No sir, it goes away immediately. I ordered the OWC 32GB ram kit; I’ll install and see if that was the root cause.

Also, some people with the same issue found that changing the GPU selection to use “Prefer Integrated GPU” solved it, but I don’t believe I can do that with an Intel. The Developer forum on Apple.com has quite a few people experiencing the same thing, so I think it’s a bug with Xcode 15.