Xcode - No such module 'Firebase'

Hi,
I watched Chris’ video entitled “Firebase Tutorial for iOS”. I got to five minutes into the video, and then I received the error message “No such module ‘Firebase’” when I tried to import Firebase. I tried command B, however, it failed to build. What can I do to fix this?

Hi Sydney,

Welcome to the community!
Did you install cocoa pods correctly? (With no errors)

Hi Mikalea,
Thanks! I’m pretty new to this but I believe everything downloaded correctly. Is there a way to make sure that its installed properly?

Take out any import statement, and see if your project will build

Hi Mikaela,

This is currently what the project looks like.

Take out the import, does the project build?

Also try Cmd+ Shift + K to clean the project and then try to build it

Also what does your podfile look like?

This is what the PodFile looks like.

@sydney

Okay that’s why it isn’t working, you haven’t added any pods to this file!

Under Pods for Dalmatian
You need to add whichever pods you want, it’ll end up looking like

Pod ‘Firebase/Analytics’
Pod ‘Firebase/Database’

You should watch this video https://youtu.be/oNKVVBN2JN0

@sydney feel free to DM me on insta, I check it more and the notifications for this app aren’t great

Instagram.com/mikaelacaron

1 Like